Category

Support

Problem z dostępem do baz danych WSCAD po aktualizacji pakietu Office

By | Support, WSCAD SUITE

Problem z dostępem do baz danych WSCAD po aktualizacji pakietu Office

Ten komunikat o błędzie dotyczy problemu z silnikiem bazy danych programu Microsoft Access (MADBE), który występuje z powodu problemów lub zmian w instalacji pakietu Office. W większości przypadków przyczyną jest aktualizacja pakietu Office.

Po pierwsze: zawsze potwierdź tę wiadomość „Nie”, aby nie uszkodzić bazy danych.

Jeśli już potwierdziłeś za pomocą „Tak”, przejdziemy do tego później.

1. Analiza stanu MS Office

Pierwszą rzeczą do zrobienia jest sprawdzenie, które składniki pakietu Office są zainstalowane w systemie.

  • Otwórz program biurowy (Word / Excel).
  • W menu “Plik-> Konto-> Informacje o Microsoft Office” możesz sprawdzić, czy Twój pakiet Office został zainstalowany jako wersja 32-bitowa czy 64-bitowa.
  • Alternatywnie, Windows 10 w Menedżerze zadań pokazuje również formę, w jakiej programy są uruchamiane.
  • Sprawdź w panelu sterowania w katalogu “Programy i funkcje”, czy i które wersje “Microsoft Access Database Engine” są zainstalowane.

2. Sprawdzenie czy oprogramowanie WSCAD uruchamia się jako wersja 32-bitowa czy 64-bitowa

W oprogramowaniu WSCAD informacja o strukturze wyświetlana jest w menu „Pomoc-> Info”.

Wersje Office i WSCAD różnią się od siebie

WSCAD jest zawsze instalowany w obu wersjach.
To, którą wersję uruchomiono, można określić za pomocą parametrów startowych.
Jeśli otworzysz zakładkę „Skrót” we właściwościach skrótu na pulpicie, wersję 64-bitową można uruchomić wpisując w polu „Element docelowy” rozszerzenie „-64”. Jeśli tego wpisu nie będzie, zostanie uruchomiona wersja 32-bitowa.
(Przykładowy cel: „C: \ WSCAD \ WSCAD SUITE \ 202x \ STARTSUITE.exe” -s -64)

post-2552_02_eigenschaften

Wersje Office i WSCAD są takie same

Wydaje się, że istniejący MADBE jest uszkodzony lub w ogóle nie występuje.
Otwórz obszar „Programy i funkcje” w „Panelu sterowania”.
Najpierw usuń wszystkie istniejące instalacje MADBE lub przeprowadź ich naprawę.

W katalogu instalacyjnym WSCAD znajdziesz folder „REDIST”, a w nim „AccessDatabaseEngine.exe” w wersji 2007, którą zalecamy w przypadku starszych instalacji pakietu Office. Jednak silnik ten dostępny jest tylko w wersji 32-bitowej.
W podkatalogach znajdziesz odpowiednią instalację MADBE dla każdej wersji pakietu Office. Wersja 64Bit wyróżnia się sufiksem „_X64”.

3. Uruchomienie oprogramowania WSCAD

Po rozpoczęciu nadal wykazują błędy.

Baza danych mogła zostać uszkodzona przez wadliwy system.
Najpierw zamknij WSCAD i otwórz katalog WSCAD.
W większości przypadków plik „PRJVERW6.MDB” znajduje się w folderze „\ BACKUPS”.
Skopiuj go do katalogu „Projects” i zamień istniejący tam plik.

Jeśli nie masz już dostępnej działającej bazy danych, możesz na początku wygenerować nowy plik zarządzania projektem, potwierdzając komunikat o błędzie przyciskiem „Tak”.

Jednym ze sposobów jest ponowne wprowadzenie projektów do zarzadzania.
(Eksplorator projektu => Upuść->Przejmij)

Innym sposobem jest utworzenie nowego folderu dla projektów i odwołanie się do niego w programie WSCAD, w obszarze „Narzędzia-> Ustawienia (Opcje) -> Katalogi”.

Następnie zaimportuj projekty.

Aby to zrobić, przejdź do starego uszkodzonego folderu, w którym znajdują się projekty. Pojawi się okno dialogowe, w którym możesz wybrać żądane projekty.

4. Problem nadal istnieje

W rzadkich przypadkach zdarza się, że system surowo odmawia dostępu. Tutaj można wybrać ścieżkę poprzez dobór odpowiedniej struktury pakietu Office.

Inni producenci oprogramowania zainstalowani na stacji roboczej.

Na pokazanym obrazku widać, jak „Access Database Engine” i „Access Runtime” współdziałają z innymi programami.

* = alternatywnie można użyć SQL

Wymienieni producenci oprogramowania są niezależnymi markami i nie mają związku z WSCAD.

Ta tabela pokazuje, które środowiska wykonawcze i MADBE mogą być używane. Jeśli program używa środowiska wykonawczego lub MADBE, a inny program używa tej samej kombinacji w wersji 32-bitowej lub 64-bitowej, należy wybrać alternatywę. Jeśli np. WSCAD SUITE X używa MADBE 2010 w wersji 32-bitowej a, AutoCAD 2010-2020 + Electrical nie może już używać MADBE 2010 w języku angielskim, to WSCAD musi teraz działać z innym MADBE lub runtime, ponieważ w przeciwnym razie nie ma alternatywy lub żadne inne rozwiązania nie zostały przetestowane przez WSCAD.

Uwaga!
Wersje WSCAD 5.x, WSCAD SUITE 2012-2014, AutCAD xx-2009 + Electrical i Fluke DMS to czysto 32-bitowe aplikacje.
Wersje WSCAD 2015-2017, WSCAD 2018, WSCAD SUITE X, WSCAD SUITE X PLUS, AutoCAD 2010-2020 + Electrical i EPLAN P8 <= 2.7 mogą być obsługiwane zarówno w wersji 32-bitowej, jak i 64-bitowej. Wszystkie przyszłe produkty WSCAD, a także wersje AutoCAD 2021-xx + Electrical i EPLAN P8> = 2.8 są aplikacjami czysto 64-bitowymi.

Oprogramowanie 32-bitowe Office / 64-bitowe WSCAD

Szczegółowy opis tego przypadku można znaleźć w:
C: \ WSCAD \ WSCAD SUITE \ 202x \ Docs \ WSCAD_SUITE_X_PLUS_64bit_i_MSOffice.pdf

Oprogramowanie 64-bitowe Office / 32-bitowe WSCAD

Po prostu zainstaluj MADBE 2007.
C: \ WSCAD \ WSCAD SUITE \ 202x \ REDIST \ AccessDatabaseEngine.exe

Następnie usuń rozszerzenie „-64” ze skrótu na pulpicie

post-2552_02_eigenschaften

Jeśli używasz już poprzedniej wersji WSCAD, 32-bitowy sterownik został już zainstalowany. Jeśli teraz spróbujesz zainstalować 64-bitową wersję sterownika bazy danych, zostanie wyświetlony następujący komunikat:

5. Nie do rozwiązania

Odinstaluj cały pakiet Office, wszystkie powiązane elementy i całe oprogramowanie WSCAD. Następnie zainstaluj pakiet Office i sprawdź przed zainstalowaniem oprogramowania WSCAD, czy zainstalowano MADBE. Jeśli tak nie jest, zainstaluj plik „AccessDatabaseEngine.exe” zgodnie z opisem w punkcie 4.
Następnie ponownie przeprowadź instalację oprogramowania WSCAD.

W tym miejscu możesz pobrać powyższy artykuł:

Ważne informacje

WSCAD SUITE I ACCESS DATABASE ENGINE 2016 64BIT

By | Support, WSCAD SUITE

WSCAD SUITE I ACCESS DATABASE ENGINE 2016 64BIT

Jeśli pokazany poniżej błąd pojawia się, gdy WSCAD SUITE uzyskuje dostęp do bazy danych Access, oznacza to, że WSCAD SUITE pracuje w trybie 64-bitowym i używa zainstalowanego na komputerze 64-bitowego aparatu Access Database Engine 2016.

Access_DB_error

Ten błąd nie pojawia się podczas korzystania z 64-bitowego aparatu Access Database Engine 2010. Wsparcie dla tego silnika zostało zakończone przez Microsoft wraz z zakończeniem wsparcia dla MS Office 2010 w październiku 2020 roku.

Możesz naprawić błąd, pobierając i instalując 64-bitowy program Access-Runtime 2016 (accessruntime_4288-1001_x64_en-en.exe) z witryny internetowej firmy Microsoft:

https://www.microsoft.com/en-us/download/details.aspx?id=50040

Ten błąd nie pojawia się w wersjach WSCAD SUITE w trybie 32-bitowym.

Informacje dotyczące zainstalowanych wersji Access Database Engine można uzyskać, wywołując pozycję Programy i funkcje w Panelu sterowania i wprowadzając access w polu wyszukiwania.

Uwaga:

Wraz z WSCAD SUITE X PLUS, Access Runtime 2016 64Bit jest instalowany w tym samym czasie co Access Database Engine 2016 64Bit. Ponadto 64-bitowy program Access Runtime 2016 jest przechowywany w katalogu instalacyjnym WSCAD SUITE X PLUS:

Redist\Access2016\accessruntime_x64.exe

Jeżeli mimo to wystąpi opisany błąd, możesz zainstalować Access Runtime 2016 64Bit z powyższej lokalizacji.

W tym miejscu możesz pobrać powyższy artykuł:

Okno startowe

Licencjonowanie oprogramowania WSCAD

By | Support, WSCAD SUITE

Licencjonowanie oprogramowania WSCAD

Licencjonujesz oprogramowanie WSCAD za pośrednictwem CodeMeter Cloud (WebDepot) za pomocą 25-cyfrowego biletu (klucz produktu, klucz licencyjny) otrzymanego od WSCAD pocztą elektroniczną. Potrzebujesz połączenia internetowego i przeglądarki internetowej z aktywowanym JavaScript, np. Google Chrome, Mozilla Firefox, Opera, Microsoft Edge (od wersji 79, oparty na Chromium). Na komputerze, na którym chcesz aktywować licencje musi być zainstalowany sterownik CodeMeter. Aktywacja licencji powoduje wygenerowanie kontenera CodeMeter z informacjami o licencji i porównanie go z chmurą CodeMeter.

Takim typem licencjonowania objęte są następujące wersje WSCAD:

  • WSCAD ELECTRIX
  • WSCAD SUITE X Plus
  • WSCAD SUITE X
  • WSCAD SUITE 2018
  • WSCAD SUITE Education

Wersja WSCAD SUITE X DEMO nie jest licencjonowana.

Począwszy od dodatku Service Pack 3 (SP3) oprogramowania WSCAD, licencjonowanie jest jeszcze bardziej uproszczone. W przypadku nowych licencji lub zmian licencji zwykle dostarczane są licencje UFC (UFC = Universal Firm Code), które są przechowywane w kontenerze CodeMeter. Kontener CodeMeter może być umieszczony na kluczu WIBU (pamięć USB WIBU) lub bezpośrednio na komputerze. Jako klient możesz teraz w dowolnym momencie przełączać między programową i sprzętową ochroną przed kopiowaniem, pod warunkiem, że jest zainstalowany klucz sprzętowy.

Więcej informacji na temat aktywacji licencji można znaleźć tutaj:
https://wscad.pl/aktywacja-licencji/

Klucz programowy (Software)

Aktywna licencja przechowywana jest w kontenerze CodeMeter na komputerze i połączona z tym komputerem.

Klucz sprzętowy (Hardware)

Do sprzętowej ochrony przed kopiowaniem potrzebny jest klucz sprzętowy (pamięć USB) dostarczony przez WSCAD. Jeśli masz już klucz poprzedniej wersji WSCAD (mini klucz WIBU), możesz go dalej używać. Duży zielony klucz WibuKey nie jest już obsługiwany od wersji WSCAD SUITE X.

Aktywna licencja przechowywana jest w kontenerze CodeMeter na kluczu sprzętowym i połączona z tym kluczem sprzętowym.

Uwaga: Jeśli podczas aktywacji licencji UFC do komputera włożony jest klucz sprzętowy, możesz wybrać, czy chcesz używać sprzętowej czy programowej ochrony przed kopiowaniem. W dowolnym momencie możesz przełączać się między sprzętową a programową ochroną przed kopiowaniem zwracając i aktywując ponownie licencję przez WebDepot.

Auto-Update

Jeśli konieczna jest zmiana licencji (np. podczas aktualizacji z Compact do Professional lub zwiększenia liczby użytkowników), zmiany są automatycznie przenoszone do WebDepot. Począwszy od dodatku SP3 oprogramowania WSCAD, podczas uruchamiania programu sprawdzany jest WebDepot, czy są jakieś zmiany w licencji. Jeśli tak, zmiany te zostaną natychmiast zainstalowane. W przypadku zmiany licencji nie musisz już ręcznie aktywować biletu w WebDepot.

Przenoszenie

Możesz przenosić licencje UFC z jednego komputera na inny. W przypadku sprzętowej ochronie przed kopiowaniem wystarczy podłączyć klucz sprzętowy do drugiego komputera, natomiast w przypadku ochrony programowej należy dezaktywować licencję i aktywować ją na drugim komputerze. W obu przypadkach sterownik CodeMeter musi być zainstalowany na drugim komputerze.

Jeśli chcesz zmienić licencję ze sprzętowej na programową ochronę przed kopiowaniem lub odwrotnie, musisz ją najpierw zwrócić, a następnie ponownie aktywować.

Wypożyczanie

Licencje sieciowe UFC można wypożyczyć z jednego kontenera CodeMeter na inny kontener CodeMeter na okres do jednego miesiąca, np. z samodzielnego komputera na laptopa. Nie ma znaczenia, czy kontener jest na komputerze, czy na kluczu sprzętowym.

Okno startowe WSCAD SUITE

Jeśli podczas uruchamiania WSCAD SUITE znajdzie dodatkowe kontenery CodeMeter na komputerze lokalnym lub w sieci, wszystkie dostępne licencje zaoferowane bedą w oknie startowym. Ponadto wyświetlane są wszystkie wykorzystane i wolne licencje.
Przed uruchomieniem oprogramowania WSCAD można w oknie startowym aktywować i dezaktywować poszczególne dodatki.
Uruchomiona licencja nie jest już dostępna w sieci, po zamknięciu WSCAD, licencja zostanie odblokowana.

Okno startowe WSCAD
Rodzaje ochrony przed kopiowaniem

Poniższa tabela zawiera przegląd możliwych rodzajów ochrony przed kopiowaniem.

Symbol

Wyjaśnienia

Operacje

Oprogramowanie WSCAD

Programowa ochrona przed kopiowaniem

UFC ACTUFC ACT:
Programowa ochrona przed kopiowaniem z licencją UFC
• Aktywacja
• Przenoszenie
• Przywrócenie
• Wypożyczenie (tylko z licencją sieciową)
• WSCAD SUITE X
• WSCAD SUITE 2018
ACTACT:
Programowa ochrona przed kopiowaniem (CodeMeterAct)
• Aktywacja
• Przenoszenie
• Przywrócenie
• WSCAD SUITE X
• WSCAD SUITE 2015/17/18
• WSCAD SUITE Education

Sprzętowa ochrona przed kopiowaniem

UFC CMDUFC CMD:
Sprzętowa ochrona przed kopiowaniem z kluczem i licencją UFC
• Aktywacja
• Przenoszenie
• Przywrócenie
• Wypożyczenie (tylko z licencją sieciową)
• WSCAD SUITE X
• WSCAD SUITE 2018
CMDCMD:
Sprzętowa ochrona przed kopiowaniem z kluczem
• Aktywacja• WSCAD SUITE X
• WSCAD SUITE 2015/17/18
WibuKeySprzętowa ochrona przed kopiowaniem z kluczem WibuKey• Aktywacja• WSCAD SUITE 2015/17/18
• WSCAD 5.x
Przegląd

Ten blog opisuje następujące działania:

Wszystkie powyższe działania opisane są na przykładzie WSCAD X.

Aktywacja licencji

Do przeprowadzenia aktywacji licencji na komputerze (np. na serwerze licencji) musi być zainstalowany sterownik CodeMeter od wersji 6.9. Jeśli sterownik CodeMeter nie został zainstalowany razem z WSCAD SUITE, należy go zainstalować osobno.

Link do sterownika CodeMeter CodeMeter User Runtime dla Windows
https://www.wibu.com/us/support/user/downloads-user-software.html

Wymagania:

  • E-mail z 25-cyfrowym biletem
  • Połączenie z Internetem
  • Podczas korzystania ze sprzętowej ochrony przed kopiowaniem klucz sprzętowy należy podłączyć do portu USB komputera.
  1. Uruchom WebDepot pod adresem: http://lc.codemeter.com/14719/depot/index.php.
  2. Wpisz 25-cyfrowy bilet (klucz produktu) w polu Ticket na stronie WebDepot i kliknij przycisk Next. Wyświetlane są produkty objęte licencją.
WSCAD, moje licencje
  1. Kliknij przycisk Aktivate licenses (Aktywuj licencje).
  2. Tylko z licencją UFC: Jeśli klucz jest podłączony do komputera, możesz wybrać, czy chcesz używać sprzętowej, czy programowej ochrony przed kopiowaniem. Kliknij wybraną opcję
WSCAD, wybór licencji
  1. W razie potrzeby wybierz żądany pojemnik CodeMeter z listy rozwijanej. W razie wątpliwości wybierz opcję Get CmContainer automatically.
  2. Kliknij przycisk Activate selected licenses now. Licencja jest aktywowana.
  3. Potwierdź pomyślną aktywację licencji za pomocą OK.

Przeniesienie licencji (wymiana komputera)

Jeśli licencja ma być używana na innym komputerze, możesz przenieść licencję ze starego komputera na nowy za pomocą WebDepot. Sterownik CodeMeter musi być również zainstalowany na nowym komputerze.

Dzięki sprzętowej ochronie przed kopiowaniem wystarczy podłączyć klucz sprzętowy do nowego komputera. Licencja nie musi być dezaktywowana, a następnie ponownie aktywowana.

Poprzez WebDepot dezaktywuj licencję w kontenerze CodeMeter starego komputera i aktywuj licencję w kontenerze CodeMeter nowego komputera.

Uwaga: Możesz również użyć funkcji „przenieś licencję”, jeśli chcesz przełączyć się ze sprzętowej na programową ochronę przed kopiowaniem na komputerze lub odwrotnie.

Warunek: licencja jest aktywowana. Potrzebujesz 25-cyfrowego biletu i połączenia internetowego.

  1. Uruchom WebDepot pod adresem: http://lc.codemeter.com/14719/depot/index.php.
  2. Wprowadź swój bilet na stronie WebDepot i kliknij Next. Wyświetlone zostaną produkty objęte licencją i ich status.
WSCAD, moje licencje
  1. Kliknij opcję Re-host licenses.
  2. Wybierz licencję, którą chcesz przenieść.
  3. Kliknij opcję Deactivate selected licenses now. Wybrana licencja zostanie usunięta z kontenera CodeMeter. Pusty pojemnik pozostaje na komputerze.
  4. Potwierdź pomyślną dezaktywację licencji za pomocą OK.
  5. Aktywuj licencję na innym komputerze. Aby to zrobić, postępuj zgodnie z opisem w dziale „Aktywacja licencji”.

Przywrócenie licencji

Jeśli korzystasz z programowego zabezpieczającego przed kopiowaniem, licencja jest przechowywana w kontenerze CodeMeter na komputerze. Jeśli kontener jest uszkodzony lub już nie istnieje (np. podczas reinstalacji systemu lub podczas aktualizacji do systemu Windows 10), możesz przywrócić licencję za pośrednictwem WebDepot. W takim przypadku na komputerze tworzony jest nowy kontener CodeMeter, w którym zapisywana jest licencja.

Uwaga: Odzyskiwanie licencji jest możliwe tylko raz.

Warunek: Kontener CodeMeter na PC jest uszkodzony lub już nie istnieje. Potrzebujesz 25-cyfrowego biletu i połączenia internetowego.

  1. Uruchom WebDepot pod adresem: http://lc.codemeter.com/14719/depot/index.php.
  2. Wprowadź swój bilet na stronie WebDepot i kliknij Next. Wyświetlone zostaną produkty objęte licencją i ich status.
WSCAD, moje licencje
  1. Kliknij Restore licenses.
  2. Kliknij opcję Restore complete CmContainer at the same computer.
  3. Zaznacz pole wyboru I accept the Conditions for CmContainer restoration.
  4. Kliknij Restore CmContainer now. Kontener CodeMeter z zawartą licencją zostanie przywrócony na komputerze.
  5. Potwierdź pomyślne przeniesienie licencji za pomocą OK.

Wypożyczenie licencji

Jeśli program WSCAD został zakupiony w wersji sieciowej z licencją UFC, można skorzystać z opcji wypożyczania licencji na określony okres (maksymalnie jeden miesiąc). Dzięki temu możesz wypożyczyć licencję z kontenera sieciowego na lokalny komputer, a licencja jest przenoszona do lokalnego, nowo utworzonego kontenera CodeMeter. Możesz teraz używać WSCAD na komputerze (np. Laptopie) bez dostępu sieci przez określony czas. Licencja może zostać zwrócona w każdej chwili.

Wymagania dotyczące komputera z licencją i komputera, na który licencję przenosimy

  • Oba wymagają tego samego systemu operacyjnego (zarówno Windows 7, jak i Windows 10)
  • Oba muszą być w tej samej sieci (192.168.xxx.xxx)
  • Żadne z nich nie może zmienić nazwy w okresie wypożyczenia
  1. Uruchom program WSCAD na lokalnym komputerze.
  2. Kliknij polecenie menu Pomoc | Wypożyczenie licencji. Otworzy się następujące okno dialogowe:
WSCAD, wypożyczenie licencji
  1. Wybierz licencję.
  2. Wybierz datę zwrotu licencji.
    Uwaga: możesz maksymalnie. podać okres wypożyczenia wynoszący jeden miesiąc. Po upływie okresu wypożyczenia licencja jest automatycznie zwracana.
  3. Kliknij przycisk Wypożyczenie. Wybrana licencja jest zapisywana w nowo utworzonym lokalnym kontenerze CodeMeter.

Możesz zwrócić licencję przed upływem okresu wypożyczenia. Przycisk Zwrot przywraca licencję z lokalnego kontenera CodeMeter do oryginalnego kontenera. Utworzony na lokalnym komputerze kontener CodeMeter jest usuwany.

Uwaga: wypożyczonej licencji nie można przenieść ani dezaktywować. Musisz ją wcześniej zwrócić.

Informacje o licencji

W oprogramowaniu WSCAD możesz sprawdzić rodzaj ochrony przed kopiowaniem, liczbę użytkowników i datę wygaśnięcia licencji.

  1. Uruchom program WSCAD na lokalnym komputerze.
  2. Kliknij polecenie menu Pomoc | Info. Otworzy się następujące okno dialogowe:

W tym miejscu możesz pobrać powyższy artykuł:

WSCAD SUITE X 64BIT UND MS OFFICE 32BIT

WSCAD SUITE X 64Bit i MS Office 32Bit

By | Support, WSCAD SUITE

Chcesz pracować szybciej i bardziej stabilnie na dużych projektach ze stronami dużego formatu dzięki lepszemu wykorzystaniu pamięci przez aplikacje 64-bitowe? Uruchom WSCAD SUITE w trybie 64-bitowym.

W Windows 10 64Bit wraz z zainstalowanym MS Office w trybie 64Bit to żaden problem! Podczas instalacji WSCAD SUITE wysyła zapytanie do MS Office o typ wersji bitowej i instaluje Access Database Engine 2010 wymagany dla baz danych WSCAD Access w wersji 64-bitowej.

W przypadku MS Office 32Bit WSCAD SUITE instaluje Access Database Engine 2010 w wersji 32-bitowej, ponieważ Microsoft uniemożliwia bezpośrednią instalację 64-bitowej wersji. W takim przypadku musisz ręcznie zainstalować Access Database Engine 2010 64Bit. Ponieważ jednak równoległa instalacja programu Access Database Engine 2010/2016 w wersji 32-bitowej i 64-bitowej może powodować problemy, należy zamienić istniejący 32-bitowy aparat bazy danych Access 2010/2016 na Access Database Engine 2007 (dla wszystkich aplikacji 32-bitowych).

Co więc należy zrobić?

  1. Odinstaluj Access Database Engine 2010/2016 32Bit
  2. Zainstaluj Access Database Engine 2010 64 Bit
  3. Zainstaluj program Access Database Engine 2007
  4. Uruchom WSCAD SUITE w trybie 64-bitowym

Ważne

WSCAD zaleca przejście z MS Office do wersji 64-bitowej. Podczas aktualizacji 32 bitowej wersji MS Office, Access Database Engine 2010 64Bit może zostać uszkodzony lub usunięty. W takim przypadku WSCAD SUITE przy uruchomieniu zgłasza, że bazy danych zarządzania projektami nie można odczytać i należy ją ponownie utworzyć. Nie możemy w tym momencie wybrać przycisku „Tak“, ponieważ WSCAD utworzy nowy, pusty plik, a dotychczasowy plik z danymi o projektach zostanie usunięty. Odpowiedz na pytanie, klikając „Nie”, zamknij WSCAD SUITE i ponownie zainstaluj program Access Database Engine 2010 64bit.

Uwagi

  • Jeśli na komputerze nie jest zainstalowany MS Office, podczas instalacji WSCAD Suite możesz wybrać, w której wersji powinien być zainstalowany Access Database Engine.
  • W 32-bitowym systemie Windows 10 WSCAD SUITE można uruchomić tylko w trybie 32-bitowym.
  • W instalacji sieciowej WSCAD Suite mogą wystąpić problemy z dostępem do współużytkowanych baz danych Access (np. Bazy danych artykułów), gdy WSCAD Suite działa w różnych architekturach, 32-bitowych / 64-bitowych. Dlatego w instalacji sieciowej wszystkie instalacje WSCAD Suite muszą być uruchomione w tej samej architekturze.

Używając polecenia menu głównego Pomoc | Info możesz sprawdzić, czy WSCAD Suite jest uruchomiony w trybie 32 czy 64 bitowym.

Sprawdzenie wersji MS Office

Excel 2010

  1. Klikamy w kartę Plik i wybieramy Pomoc
  2. Po prawej stronie ujrzymy jaką mamy wersję programu Excel

Excel 2019

  1. Klikamy w kartę Plik i wybieramy opcję Konto
  2. Po prawej stronie klikamy w kwadratowy przycisk Excel informacje
  3. Pojawi się nowe okno dialogowe Microsoft Excel dla Office 365 – informacje (lub podobne)
  4. Na samej górze jest zawarta informacja jaką wersję Excela posiadasz

Odinstalowanie Access Database Engine 2010/2016 32Bit

  1. Otwórz Panel sterowania i przejdź do Programy i funkcje.
  2. Wyszukaj zainstalowane wersje Access Database Engine.
  3. Odinstaluj wszystkie wersje Access Database Engine 2010/2016.

Instalacja Access Database Engine 2010 64 Bit

  1. W menu Start systemu Windows przejdź do katalogu System i kliknij prawym przyciskiem myszy pozycję Wiersz polecenia.
  2. Z menu kontekstowego wybierz pozycję Więcej | Uruchom jako administrator.
  3. W wierszu polecenia przejdź do katalogu instalacyjnego WSCAD:
    cd c:\WSCAD\WSCAD SUITE\2019\ (ścieżka zależy od instalacji)
  4. Następnie, aby zainstalować aparat bazy danych Access w wersji 64-bitowej, wprowadź następujące polecenia:
    cd Redist \ Access2010
    AccessDatabaseEngine_X64.exe /passive
    Uwaga: Jeśli używasz angielskiej wersji 64-bitowej systemu Windows 10, przejdź do trgo katalogu:
    cd Redist\EN\Access2010
  5. Tylko jeśli korzystasz z MS Office 2010, wprowadź kolejno te dwa polecenia dla wpisów rejestru w wierszu polecenia:
    Office_2010_ACE1.reg
    Office_2010_ACE2.reg
  6. Tylko jeśli korzystasz z MS Office 2013, wprowadź kolejno te dwa polecenia dla wpisów rejestru w wierszu polecenia:
    Office_2013_ACE1.reg
    Office_2013_ACE2.reg

Instalacja Access Database Engine 2007

  1. W Eksploratorze Windows przejdź do katalogu instalacyjnego WSCAD:
    cd c: \ WSCAD \ WSCAD SUITE \ 2019 \ (ścieżka zależy od instalacji)
  2. Otwórz folder Redist.
  3. Kliknij dwukrotnie plik AccessDatabaseEngine.exe, aby zainstalować aparat bazy danych Access 2007.

Uruchomienie WSCAD SUITE w trybie 64-bitowym

  1. Na pulpicie kliknij prawym przyciskiem myszy ikonę WSCAD SUITE i wybierz menu Właściwości.
  2. Kliknij kartę Skrót.
  3. W polu Element docelowy dodaj przyrostek na końcu -64 (ze spacją), np.
    „C: \ WSCAD \ WSCAD SUITE \ 2019 \ STARTSUITE.exe” -s -64

W tym miejscu możesz pobrać powyższy artykuł:

Poprzez dalsze korzystanie z witryny wyrażasz zgodę na korzystanie z plików cookie. Więcej informacji

Strona używa plików cookies, dzięki którym może działać lepiej. Korzystanie z tej strony bez zmiany ustawień dotyczących tych plików oznacza, że będą one zapisywane na Twoim urządzeniu. Zmiany ustawień cookies możesz dokonać w swojej przeglądarce internetowej.

Zamknij